Sie sind nicht angemeldet.

  • Anmelden


Dies ist unser altes Forum, es dient nur noch zur Information
Besuchen Sie unser neues LCN-Forum!

1

Dienstag, 3. Mai 2016, 21:13

OpenHAB

Hallo,

ich teste gerade das LCN OpenHAB Binding für Version 1.8.2 auf meinem RaspberryPi 3.
Leider funktioniert einiges nicht so, wie ich erwartet hätte.

Wenn ich z.B.

Quellcode

1
2
// Semgent 000, Modul M050, Ausgang 2, kurz, Taste A2
Switch Licht_EG_Kueche_Theke			"Licht Küche Theke [%d]"		(EG_Kueche)		{lcn="[lcn:OUTPUT_STATUS.S0.M050.1], [ON:lcn:ON.S0.M050.1.1s], [OFF:lcn:OFF.S0.M050.1.1s]"}

in der items einbinde, dann kann ich das Lich nur ausschalten.
Wenn ich dagegen:

Quellcode

1
Switch Licht_EG_Kueche_Theke2			"Licht Küche Theke [%d]"		(EG_Kueche)		{lcn="[lcn:OUTPUT_STATUS.S0.M050.1], [ON:lcn:TOGGLE.S0.M050.1.1s], [OFF:lcn:TOGGLE.S0.M050.1.1s]"}

nehme, dann kann ich das Licht passend ein- und ausschalten. Hat hierfür jemand eine Erklärung?


Gruß
Thomas

Beiträge: 65

Wohnort: Erfurt

Beruf: Softwareentwickler

2

Mittwoch, 4. Mai 2016, 03:17

Hmm. Nicht so richtig, das obige sieht richtig aus. Steht denn etwas im Log bzgl. Syntaxfehler oder so? Das Segment kannst Du wahrscheinlich weg lassen. Probiere auch mal, die Rampe weg zu lassen. Ein (funktionierender) Switch von mir sieht so aus:

Quellcode

1
Switch Light_EG_OfficeWall "Büro Wand" <light> (gWohnen) {lcn="[pi:OUTPUT_STATUS.0.8.2], [ON:pi:ON.0.8.2], [OFF:pi:OFF.0.8.2]"}
LCN im EFH seit 2014

3

Donnerstag, 5. Mai 2016, 05:29

Habs jetzt mal so abgeändert, wie Du es hier geschrieben hast und es funktioniert. Danke!
Wobei es egal ist, ob mit oder ohne Rampe.

Ähnliche Themen